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Building an Ad Hoc Report 
 
There might be times when there is not a standard report that satisfies your reporting 
needs.  In that case, you will need to build an ad hoc report.  You will start by 
creating a new report and adding the columns of your choice from the catalog.  You 
will then have the ability to set it up with your own groupings, filters, and format. 
 
Creating a New List Report 
 
A List report is a report made up of any number of columns.  New reports can be 
created by clicking the New button on the PowerBar.  It opens the default template 
which includes the State of Mississippi logo and is set up to print in landscape format 
 
When a new report is created by selecting the File/New command, a Palette window 
opens showing six templates. Templates can provide a head start with both the 
contents and the layout of a report.  With the Impromptu templates, a user can 
simply add the appropriate data to the template to create a report.  Several basic 
templates have been designed specifically for the State of Mississippi.  The default 
template on the palette is labeled Mississippi Landscape.  The Mississippi Portrait 
template also contains the log, but defaults to a vertical orientation.  The List Report 
template is blank (without a logo, header, or footers). 
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After creating a new report, the Query Dialog box opens automatically.  The Catalog 
box below shows the highest-level folders contained within the catalog. 
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Users can now open many levels of embedded folders in the Catalog box to see the 
data items available for the report. 
 
 Folders--meaningful groupings of information (e.g. Budget Ledger Details, 

General Ledger Details) 
 

 
 

 Columns - individual items of information (e.g. Agency Name, Agency 
Number, Fund Name, Fund Number) 

 

 
 
 Conditions - saved condition (e.g. Encumbrances) and calculation (e.g. 

Budgeted and Non-Budgeted Expenditures) specifications 
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The Training Catalog 
 
During your Impromptu training, we will focus on financial information in the Training 
section of the catalog.  It is divided into three main folders-- Fund/Object, 
Vendor/Fund/Major Object and Code Tables.  As you examine the hierarchy, you will 
see layers of folders and within those folders, columns you will want to use for your 
reports.  Only columns at the very highest level are included in the following 
description. 
 

Folder : Training 
Folder : Fund/Object 

Folder : Agency/Fund 
Folder : Time 
Folder : Account Codes 
Org Code 
Activity Code 
Bud Function Code 
Folder : Dollar Amounts 
 Folder:  Expenditures 

Folder:  Encumbrances 
Folder:  Pre Encumbrances 

Data Source 
Folder : Vendor/Fund/Major Object 

Folder : Agency/Fund 
Folder : Time 
Folder : Account Codes 
Folder : Vendor 
 Folder:  Vendor Addtl Info 
  Folder:  Vendor Minority Certifications 
Folder : Dollar Amounts 
 Folder:  Expenditures 

Folder:  Encumbrances 
Folder:  Pre Encumbrances 

Data Source 
Folder : Code Tables 

Folder : Agency Info (SAAS) 
Folder : Address 

Folder : Provider Information  
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Choosing the Data 
 
The Data tab in the Query Dialog box displays the contents of the catalog from 
which you can select the data items you want in your query.  You can select data 
items in the Catalog box and add them to the Query Data box by: 
 
 Dragging columns to the Query Data box 
 Selecting columns and choosing the Add button, or 
 Double-clicking a column in the Catalog box 
 

 
 
The order of the columns in the Query Data box determines the column order in the 
report.  Columns can be moved and dragged to another location within the Query 
Data box.  Columns can be removed from the query with the Remove button.  
Columns can also be added that do not display in the report by selecting the column 
and choosing the Mark for Insertion button to toggle the insertion status to off. 
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Exercise 1 
 
The purpose of this first ad hoc report, is to create a report similar to the 
Expenditures $ standard report.  The report should reflect expenditures greater than 
$10,000 for January 1997.  It should be sorted by Bud Exp Amt and grouped by 
Agency name as shown below. 
 

 
1.  Click the New button on the PowerBar 
 
2.  Add columns to your report 

 Double click the Training folder to open it 
 Open the Fund/Object folder 
 Open the Agency/Fund folder 
 Double click Agency Nm (SAAS) and Agency Nbr (SAAS) to add them   

 to the Query Data box 
 Close the Agency/Fund folder 
 Open the Time Period folder 
 Double click Budget Year, Accounting Month, and Allotment Period to 

  add them to the Query Data box 
 Close the Time folder 
 Open the Account Codes folder 
 Double click Minor Obj Code and Major Obj Code to add them to the 

  Query Data box 
 Close the Account Codes folder 
 Scroll below the Account Codes folder 
 Double click Org Cd, Activity Code, and Bud Function Code to add  

  them to the Query Data box 
 Open the Dollar Amounts folder 
 Open the Expenditures folder 
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 Double click Bud Exp to add it to the Query Data box 
 
3.  Sort the data by Budget Expenditure Amount in descending order 

 Select the Sort tab in the Query dialog box 
 Select Bud Exp 
 Click the Descending button 

 
4.  Group the data by Agency and Major Object Code 

 Select the Group tab in the Query dialog box 
 Select Agency Nm (SAAS) 
 Click the Group button 
 Select Agency Nbr (SAAS) 
 Click the Associate button 
 Double click Major Obj Code 

 
5.  Filter the data to Budget Year 1997 and Accounting Month 07 

 Select the Filter tab on the Query dialog box 
 Double click the Report Columns icon 
 Double click Budget Year 
 Double click =  
 Double click string 
 Type 1997 
 Click on the ... 
 Double click and 
 Double click Report Columns 
 Double click Agency Nbr (SAAS) 
 Double click =  
 Double click string 
 Type 130 
 Click on the ... 
 Double click and 
 Double click Report Columns 
 Double click Accounting Month 
 Double click =  
 Double click string 
 Type 07 
 Click on the ... 
 Double click and 
 Double click Report Columns 
 Scroll down to Bud Exp and double click on it 
 Double Click > 
 Double click number 
 Enter 10000 
 Choose OK 

 
 
 



4103 – MERLIN Building an Ad Hoc Report  V5 11/02/2011 

_________________________________________________________________________________________ 
4103 MERLIN Building an Ad Hoc Report.doc  Page 10 of 23  

6.  Modify the title in the List Header 
 Click on List Report Title 
 Double click on the text and delete the default text 
 Enter title Expenditures by Agency 

 
7.  Save the report 

 Click File 
 Click Save As and type My First Report for the filename 
 Click OK 
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Creating a SmartSummary 
 
Summaries allow you to aggregate data at various levels within reports.  When you 
create a SmartSummary, the value that is calculated will reflect the group it is 
associated with. Smart Summaries are dynamic and are calculated based on their 
position in the report.  It will calculate a Monthly Total if you put it in the Monthly 
footer, and it will calculate the Annual Grand Total if you put it in the Grand Total 
footer.  When you make a new SmartSummary, a special SmartSummary icon 
appears below the group that the SmartSummary is associated with in the Group 
Order box. 
 
Adding Text Frames  
 
A group footer is automatically added for each distinct group within the report when 
a SmartSummary is created.  To label the footer, add a text frame to the footer.  To 
create a text frame: 
 
 Click the Text Frame button on the Layout PowerBar 
 (The mouse pointer changes to a Text icon) 
 Position the pointer where you want the upper-left corner of the text 
 Drag the mouse diagonally until it is the size you want 
 Release the mouse button  
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Exercise 2 
 
Create the following vendor payment report for one vendor for all periods in Budget 
Year 1997.  Create a Monthly Total and Grand Total using the Smart Summary 
feature, and add text frames to label the totals. 
 
 
1.  Click the New button on the PowerBar 
 
2.  Add columns to your report 

 Open the Training folder 
 Open Vendor/Fund/Major Obj folder 
 Add these columns to the Query Data box 

Vendor Nbr 
Vendor Name  
Agency Nm (SAAS) 
Agency Nbr (SAAS) 
Budget Year 
Accounting Month 
Bud Exp 
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3.  Sort, group and filter the data 
 Sort the data by Bud Exp amount in descending order 
 Group the data by Agency Name and Accounting Month 
 Filter the data to the vendor name OFFICE DEPOT - JACKSON, Budget Year 

1997, and Agency number 651 
 Click OK to retrieve the data 
 
4.  Edit and format the report  
 Delete the Vendor Name column 
 Move the Accounting Month column next to the Agency Name column 
 Rename the Bud Exp Amt column to Expenditures 
 Make all column headings bold 

 Click on the first column and control click on the others to highlight 
 Click Bold on the PowerBar 
 Change the font to a larger size 

 
5.  Create a Smart Summary 
 Select the Expenditures column 
 Click the Total Power Button 
 
6.  Insert the words Monthly Total in the group footer 
 Click the Text Frame button in the PowerBar 
 Click in the footer 
 Drag the text frame icon to make a rectangle 
 Type Monthly Total 
 Highlight Monthly Total and click Bold on the PowerBar 
 Press the [ESC] key 
 
7.  Add text frames for an Agency Total and a Grand Total 
 
8.  Modify the title 
 
9.  Save the report as My Second Report and close the report 
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Creating a Filter with the PowerButton 
 
Use the filter button on the PowerBar to quickly perform simple filter operations such 
as showing Vendor Payment Hold indicated with a “Y”.   To create a basic filter using 
the PowerBar button: 
 Select a data item or CTRL + click to select multiple items 
 Click the Filter button on the PowerBar 
 

 
 
Impromptu retrieves records based on the data values you selected; all other data is 
filtered out of the query. 
 
More Easy Ways to Create Filters using the PowerButton 
 
The filter power includes a drop down button that allows you access to a variety of 
filter options from the filter definition dialog box.   

 
 
 Select one or more values in a column. 
 Click the Filter drop-down button. A drop-down menu appears. 
 Select a filter operator from the drop-down menu. 

o To filter on the selected values, click In. 
o To filter out the selected values, click Not In. 
o To filter the selection on a given range, click Between. 
o To filter out the selection on a given range, click Not Between. 
o To filter the selection based on one or more values, click an operator 

such as =, <>, <, <=, >, >=. 
 

Note: The contents of the Filter drop-down menu vary depending on the columns 
you select to filter on. 
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 Position the cursor over the arrow that appears at the right of the drop-down 
menu. A fly-out menu appears. 

 
 From the fly-out menu that lists available options, do one of the following: 
 

o To filter a report on one or more data items currently highlighted, click 
Selection. 

o To enter one or more numbers upon which to filter, click Number. 
o To enter one or more text strings upon which to filter, click String. 
o To enter one or more dates upon which to filter, click Date. 
o To enter one or more times upon which to filter, click Time. 
o To enter a date and time variable upon which to filter, click Date-time. 
o To enter one or more intervals upon which to filter, click Interval. 

 
Note:  The contents of the Filter fly-out menu vary depending on the columns you 
select to filter on. 
 
 If you chose 
 

o Selection, the filter is automatically applied to the report 
o String, the String dialog box appears, where you can enter or select 

the required item or items and click OK 
o Select Values, a Select Value dialog box appears, where you can 

select the required item from the list provided 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



4103 – MERLIN Building an Ad Hoc Report  V5 11/02/2011 

_________________________________________________________________________________________ 
4103 MERLIN Building an Ad Hoc Report.doc  Page 16 of 23  

Creating a Calculation 
 
A calculation is an expression that calculates a new data item based on existing data 
items.  For example, you can define a calculation that creates a column summarizing 
Bud Exp Amt and Non Exp Amt.  To create a calculation, select Calculation from the 
Insert menu and place the pointer at the new column location.  A Dialog box opens 
with options for entering the Name and the calculation expression.  Components you 
can use in the expression are listed in the Options box.  Operators that you can use 
in the expression are below the Expression box as buttons.  Use the Delete or 
Backspace key if you make a mistake. 
 
Fit a Wide List Report to a Page  
 
You can automatically scale down a wide list report by utilizing the fit to page option.   
Steps to Fit to Page: 
 
 From the File menu, click Page Setup. 
 In the List Frames box, click the Fit to Page check box. 
 Click OK. 

 
 
Helpful hints: 
 Page Fit To Page does not affect the Page Layout view or Screen Layout 

view of a report. 
 Fit To Page scales down a wide list report while maintaining the 

horizontal/vertical ratio.  
 Fit To Page should not be used with the Repeat This Column on Every Page 

option. 
 Fit To check box is available only when working with a list report.  
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Repeat Column Header on Each Page  
 
If you allow a report to print over subsequent pages, the column information can lose 
its context.  In such a case, you can repeat column heading on subsequent pages so 
that the data retains the desired context.   
 
 Select one or more columns in your report. 
 Select Properties from the Format menu, and click the Printing tab. 
 Click the Repeat This Column On Every Page check box. 
 Click OK. 
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Insert a Report Header on Each Page 
 
You can easily have a report header print on each page of the report when needed for a 
point of reference by following these steps: 
 

 Choose Page Layout from the View menu. 
 Choose Boundary Lines from the View menu. 
 Choose Zoom from the View menu, select Whole Page. 
 Click OK. 
 Choose Page Setup from the File menus, select Page Header. 
 Click OK. 
 Select the Header area of your report and click and drag to enlarge the 

Header area. 
o If your report does not have a text box with header information 

create a text box for you report header. 
o If your report already has a text box with header information, and 

you want the text box to appear in the header, simply select the text 
box and drag into the header area.   

o Other objects, such as the State of MS seal may also be added to 
the header by the selecting the item and dragging it to the header 
area.   

o Once you have moved items to the header, you may delete the box 
by: 
 Select the area where the report text box header information 

was moved from (this will highlight the area). 
 Depress the Delete key 

 
Return report to its original layout: 
 

 Choose Screen Layout from the View menu 
 Choose Boundary Lines from the View menu   
 Choose Zoom from the View menu, select 100% 
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Exercise 3 
 
Create a Vendor Report to show only vendors with a Payment Hold of Y for Fund 
Numbers 3400 and 3408.  Include subtotals and totals of Budget Expenditure 
Amount and create a column for Total Expenditures.  Your report should appear as 
shown below. 
       

 
 

1.  Click the New button on the PowerBar 
 
2.  Add columns to the report from the Vendor/Fund/Major Obj folder 

Agency Nm (SAAS) 
Agency Nbr (SAAS) 

 Fund Number 
Budget Year 
Vendor Name  
Vendor Nbr 
Vendor Payment Hold Ind 
Bud Exp  
Non Bud Exp  

 
3.  Group the report by: 

Agency Nbr (SAAS), Associate Agency Nm (SAAS) 
  Vendor Nbr, Associate Vendor Name 
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4.  Filter the report so that only vendors with a payment hold indicated by Y 
are reported for Budget Year 1997, Agency Number 401. 
 
5.  Click OK to retrieve the report 
 
6.  Filter the Fund Number for 3400 and 3408. 
 Click 3400 in the Fund Number column 
 Control Click to select 3408 in the Fund Number column. 
 Click the Filter drop-down button. A drop-down menu appears. 
 Select the filter operator from the drop-down menu, click In. 
 From the fly-out menu that lists available options, click Selection. 

 
7.  Insert footer and create a subtotal by Vendor 
 Click a value under Vendor Number column 
 Click the Footer Power button 
 Click a value on the Bud Exp column 
 Click the Total button on the PowerBar 
 
8.  Add a text frame for the Subtotal footer 
 
9.  Create a calculated column to sum the Two Expenditures columns 
 Choose Calculation from Insert menu 
 Click to the right of Non Bud Exp 
 Type Total Expense in the Name box 
 Open Report Columns 
 Double click Bud Exp 
 Double click the + sign 
 Open Functions 
 Double click ifnull-numeric 
 Open Report Columns 
 Double click Non Bud Exp  
 Double click number 
 Click OK 
 
10.  Delete columns and arrange the columns as shown in the example on the 
preceding page. 
 
11.  Add a Title as shown 
 
12.  Save report as My Third Report and close the report 
 



4103 – MERLIN Building an Ad Hoc Report  V5 11/02/2011 

_________________________________________________________________________________________ 
4103 MERLIN Building an Ad Hoc Report.doc  Page 21 of 23  

Aligning Objects in a Report 
 
When footers are added to a report, there is an easy way to align data items.  After 
choosing Align from the Format menu, a Dialog box opens.  Select the Align tab.  
There is a Vertical box for setting the vertical alignment of the report objects and a 
Horizontal box to set the horizontal alignment of the report objects.   
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Exercise 4 
 
Create a report for WILDLIFE FISHERIES AND PARKS showing expenditures 
grouped by funds for budget year 1997.  Include totals only for each fund and a 
grand total.  Your report should appear as shown below 
 
Note: You will receive a warning on this exercise about exceeding the 10,000 
rows limit.  When you receive this warning, click Yes to continue. 
 
 
1.  Click the New button on the PowerBar 
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2.  Add columns to the report from the Fund/Object folder. 
Agency Nbr (SAAS) 
Agency Nm (SAAS) 
Fund Name 
Fund Grp Type 
Fund Number 
Budget Year 
Major Obj Code 
Bud Exp 
Non Bud Exp 

 
3.  Filter the report 

Agency Number = 464 
Budget Year = 1997 

 
4.  Group the report by Fund Name and by Major Object Code 
 Click OK 
 
5.  Delete columns except for those shown in the above example. 
 
6.  Format the report 
 Click a value under Bud Exp 
 Choose Data from the format menu 
 Choose #,##0.00 from the Positive drop down menu 
 
7.  Create a Total for each Fund 
 Click on a value under Fund Name 
 Click Footer on the PowerBar 
 Click a value under Bud Exp 
 Click the Total button on the PowerBar 
 
8.  Align the Total 
 Highlight a Total value 
 Choose Align from the Format Menu 
 Click the first drop down menu in the Horizontal Alignment drop down box and 

review the selected alignment. 
 Click OK 
 
9. Make any other changes to the report so that it appears as shown in the 

above example. 
 
10.  Save and Close 
 


